SAX2: Namespace proposal

Ray Waldin rwaldin at
Sun Dec 19 10:50:24 GMT 1999

James Clark wrote:
> Here's an alternative proposal:

My comments:

1) Nice!  

2) Please add the prefix param to endNamespaceDecl().  This makes application
management of prefix stacks somewhat simpler.

3) Since the localName param and getLocalName methods play different roles for
different NamespaceProcessingLevels, you may want to rename them using the more
generic name "name", as in:

DocumentHandler.startElement(String namespaceURI, String name, AttributeList


AttributeList.getName(int i);


xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at
Archived as: and on CD-ROM/ISBN 981-02-3594-1
To unsubscribe, mailto:majordomo at the following message;
unsubscribe xml-dev
To subscribe to the digests, mailto:majordomo at the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at

More information about the Xml-dev mailing list