ModSAX (SAX 1.1) Proposal
Don Park
donpark at quake.net
Tue Feb 16 00:09:52 GMT 1999
David,
Here is my counter proposal:
public interface ModularParser extends Parser {
boolean hasModule(String moduleName);
// returns true if the named module is supported, false otherwise.
// return value does not indicate whether the module is enabled or
not.
// module version should be encoded in the module name
boolean getModuleState(String moduleName);
// returns true if the named module is enabled, false otherwise.
boolean setModuleState(String moduleName, boolean enable);
// enables or disables a named module.
// Result reflects the resulting state of the module.
ModuleHandler getModuleHandler(String moduleName);
// returns named module's handler or null if there is no previously
installed
// handler or if the module is not supported.
boolean setModuleHandler(String moduleName, ModuleHandler handler);
// sets named module's handler.
// returns true if successful or false if failed to set the handler
due to
// lack of support or other reasons.
// following two might be more controversial but they are definitely
useful.
Object getModuleProperty(String moduleName, String propName);
boolean setModuleProperty(String moduleName, String propName, Object
propValue);
}
public interface ModuleHandler {
// still empty
}
Differences are:
1. Does not use exception
2. Combined features with handler (liason?) types
3. Names changed for clarity and coherency
This is a 'grab bag' proposal so please take any idea you find useful and
throw away the rest.
Don Park
Docuverse
xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at ic.ac.uk
Archived as: http://www.lists.ic.ac.uk/hypermail/xml-dev/ and on CD-ROM/ISBN 981-02-3594-1
To (un)subscribe, mailto:majordomo at ic.ac.uk the following message;
(un)subscribe xml-dev
To subscribe to the digests, mailto:majordomo at ic.ac.uk the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at ic.ac.uk)
More information about the Xml-dev
mailing list