should FOP require JDK1.2.x?

Robert C. Lyons boblyons at
Sun Sep 19 19:08:07 BST 1999

James Tauber wrote:
     "I'd be interested in hearing people's views on the simple question: should
     FOP (my XSL formatter/renderer) require JDK1.2.x? At present it works with

     What are other XML developers doing? Should I stick to 1.1.x compatibility?
     Or can I require 1.2.x without offending too many people?"


One advantage of sticking with 1.1.x is that IE 4.0 and IE 5.0 include
Microsoft's Java VM, which supports Java 1.1.x, but not Java 1.2.x.
I suspect that many of your users have IE 4.0 or 5.0 on their PCs, 
but not JDK 1.2.x.

Also, the last time I checked (several months ago), IBM's Java 
virtual machine for AIX supported Java 1.1.x, but not 1.2.x.


Bob Lyons
EC Consultant
Unidex Inc.
boblyons at

xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at
Archived as: and on CD-ROM/ISBN 981-02-3594-1
To (un)subscribe, mailto:majordomo at the following message;
(un)subscribe xml-dev
To subscribe to the digests, mailto:majordomo at the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at

More information about the Xml-dev mailing list