SAX: Naming and Packaging (question 10 of 10)

Peter Murray-Rust peter at
Sun Jan 4 11:26:56 GMT 1998

>It is essential that we have unlimited control over any namespace that
>we use, and that the package name be neutral enough that those
>programmers with strong allegiances to the S*n, M*******t, and
>N******e armed camps all feel comfortable using it.  This issue
>affects only Java.

Firstly, I would be personally entirely happy for it to be based on Without David's effort this would not be off the ground.
However I know this is a potentially sensitive area and we must tackle it

I agree strongly that it should be domain-name based. This requires an
organisation (not just a person). Among the considerations are:
	- an organisation of permanency
	- an organisation of effective neutrality
	- a organisation with the trust of the community
	- an organisation that may (de facto) give some sort of blessing to this
	- an organisation that does not wish to 'own' the effort.
	- an organisation which is not compromised by the effort.
	- there may be a resource implication - i.e. people will look to that org
for the latest version, etc.

This is a general problem and I'm sure attempts have been made to solve it
already. I think that there may be non-commercial orgs who are aware of
this problem (learned socs, international orgs, etc.) and 
	If there are people who have concerns that they wouldn't wish to post
publicly, I am happy to receive them in confidence and - if necessary - to
represent them anonymously.

Classes ...
>  com.microstar.sax.XmlParser		the XML parser interface
>  com.microstar.sax.XmlApplication	the XML application interface
>  com.microstar.sax.XmlAppBase		the application base class,
>                                        or adaptor.
>Other possible names include "XmlProcessor" instead of "XmlParser"

I am afraid that the language the spec uses is very confusing in that
"processor" seems to be identical with what most people call "parser". I
therefor think that "processor" should be avoided, even though it is the
spec term. 

I also think that we should use spec terms wherever possible and refer to
the spec. Thus if we have "getAttValue()" it should refer to [10] in the


Peter Murray-Rust, Director Virtual School of Molecular Sciences, domestic
net connection
VSMS, Virtual Hyperglossary

xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at
Archived as:
To (un)subscribe, mailto:majordomo at the following message;
(un)subscribe xml-dev
To subscribe to the digests, mailto:majordomo at the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at

More information about the Xml-dev mailing list