First try with Jumbo

Peter Murray-Rust peter at
Wed Jan 28 20:41:24 GMT 1998

At 12:32 28/01/98 -0500, [a correspondent] wrote [privately] :
>I've just tried Jumbo (9801) on my system (Linux 2.0.x and JDK 1.1.3),
>with the following command line from the installation directory:
>  java jumbo.sgml.Jumbo scene1.sgm
>The program tries to load a few files from absolute paths, then fails
>angrily.  Here are the first three:
>- "/jumbo/mimetypes.xml" instead of "jumbo/mimetypes.xml" 
>- "/jumbo/sgml/html/schema.xml" instead of
>  "jumbo/sgml/html/schema.xml" 
>- "/scene1.sgm" instead of "scene1.sgm"

This is the sort of thing that saps enthusiasm in the middle of the night
:-) (Actually it's still early evening).

I have had had *awful* problems with files/URLs under 1.02 (and I don't
know it gets much better later). I thought I'd fixed this one. The problem
is that not all interpreters/virtual machines seem to behave consistently.
I started development with (javac,java) under Solaris; then when I moved to
((javac|jvc)|(java|jview) problems arose. java/jview do not behave
consistently - some have backslashes, other have slashes in files/URLs.
Another problem is that, String) seems to have bugs in
some implementations when URL is the current directory (I think this is
where the leading slash comes from). I *thought* I'd fixed it. I'll try to
revisit it, though I don't have a local UNIX system which makes it tricky.
I will have to wake one up.

The number of possible combinations I have to test is:

There are also different flavours of UNIX and some have very poor
performance. This is a write-once, debug-many problem.

I suggest the following:
	- if you have W95, then it should behave as I have suggested
	- if you have UNIX, try:
		- using full URLs instead of scene1.sgm (I think it should work without
the ancillary files)
		- or load jumbo without a file on the command line and use File | "Open
XML" to read in scene1.sgm
		- or try from a different directory. ("." in the classpath may cause

Performance note. JUMBO reads Lark.xml fine, but struggles on my PC with
pr.xml (the PR in xml). This fails (StackOverflowError) with java, but
works with jview. The navigation is then not too bad. It takes about 15
secs to find all given element types in the document (i.e. tree traversal).
None of this is optimised. So - at present - the effective limit of
documents is about 100K I suspect (though it's probably more dependent on
the node count).
This is the price paid at present for making every node displayable,
editable, reconfigurable, etc. 

On a constructive note - I suspect we shall need some sort of configuration
file for this. JAR files should help with this sort of thing?


Peter Murray-Rust, Director Virtual School of Molecular Sciences, domestic
net connection
VSMS, Virtual Hyperglossary

xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at
Archived as:
To (un)subscribe, mailto:majordomo at the following message;
(un)subscribe xml-dev
To subscribe to the digests, mailto:majordomo at the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at

More information about the Xml-dev mailing list