Attributes vs. text content

Erik James Freed ejfreed at infocanvas.com
Wed Sep 22 00:12:27 BST 1999


Point well taken, and this just shows to go you that mixing implementation
and abstraction causes funny things to happen. And lets be fair about what
an 'attributeless' XML might look like:

<?xml?>
	<xml:version> 1.0 </xml:version>

	<!-- the rpc package -this is temporary we are porting off of this -->
	<xmlns:rpc> http://www.w3.org/rpc </xmlns:rpc>

	<xmlns:html> http://www.w3.org/html </xmlns:html>

	<!-- the query name space package -this is the version 1 is this right? -->
	<xmlns:xql> http://www.w3.org/xql </xmlns:xql>

	<xmlns:xtype> http://www.w3.org/xtype </xmlns:xtype>

	<rpc:methodCall>
		<rpc:type> asynchronous </rpc:type>
		<rpc:completion> callback </rpc:completion>
		<rpc:name> xmlbased.cgi.named.foo </rpc:name>
		<rpc:argument>
			<rpc:ordinal>1</rpc:ordinal>
			<xtype:type> foo.bar.goo </xtype:type>
			<rpc:pack> binary-reverse </rpc:pack>
			<rpc:content>
				<xql:query> foo/*&//.$^# </xql:query>
			</rpc:content>
		</rpc:argument>
		<rpc:argument>
			<rpc:ordinal>2</rpc:ordinal>
			<xtype:type> foo.bar.text </xtype:type>
			<xtype:encoding> ISO9087345 </xtype:encoding>
			<rpc:pack> binary-reverse </rpc:pack>
			<rpc:content>
				<html:p> this is a paragraph </html:p>
			</rpc:content>
		</rpc:argument>
	</rpc:methodCall>


Is this potential full featured RPC more or less readable than its
equivalent using attributes?

Useability studies in my experience (YMMV) show that what one is used to
often seems the 'easiest' or 'best' and this works in both directions, even
if
there are absolute comprehension or speed issues with one or the other. I
can
mention that the above seems more readable to *me*, but I come from a
different background,
and it is merely subjective anecdotal evidence.

Again, I am not trying to redefine XML fundamentals on the fly in a few
emails, but I think that
the issues are more complicated and far reaching than is being admitted
here.

Thoug again, and even more importantly, this is all quite moot as it is not
going to change.

erik

> -----Original Message-----
> From: owner-xml-dev at ic.ac.uk [mailto:owner-xml-dev at ic.ac.uk]On Behalf Of
> John Tigue
> Sent: Tuesday, September 21, 1999 2:04 PM
> To: xml-dev
> Subject: Re: Attributes vs. text content
>
>
> joubin at inch.com wrote:
> |   Consider:
> |
> |   <?xml version="1.0"?>
> |   <methodCall type="asynchronous">
> |      <methodName>xmlbased.cgi.named.foo<methodName>
> |        // .. etc.
> |   </methodCall>
> |
> |     v.s.
> |
> |   <?xml version="1.0"?>
> |   <methodCall>
> |      </asynchronous>
> |      <methodName>xmlbased.cgi.named.foo<methodName>
> |        // .. etc.
> |   </methodCall>
>
>
> Wouldn't that be:
>
> <?xml?>
>   <?version?>1.0<?/version?>
>
> <methodCall>
>    </asynchronous>
>    <methodName>xmlbased.cgi.named.foo<methodName>
>      // .. etc.
> </methodCall>
>
>
> or are pseudo-attibutes ok?
>
>
> /John
>
> --
> John Tigue
> john.tigue at tigue.com
> http://www.tigue.com
>
>
>
> xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at ic.ac.uk
> Archived as: http://www.lists.ic.ac.uk/hypermail/xml-dev/ and on
> CD-ROM/ISBN 981-02-3594-1
> To (un)subscribe, mailto:majordomo at ic.ac.uk the following message;
> (un)subscribe xml-dev
> To subscribe to the digests, mailto:majordomo at ic.ac.uk the
> following message;
> subscribe xml-dev-digest
> List coordinator, Henry Rzepa (mailto:rzepa at ic.ac.uk)
>
>


xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev at ic.ac.uk
Archived as: http://www.lists.ic.ac.uk/hypermail/xml-dev/ and on CD-ROM/ISBN 981-02-3594-1
To (un)subscribe, mailto:majordomo at ic.ac.uk the following message;
(un)subscribe xml-dev
To subscribe to the digests, mailto:majordomo at ic.ac.uk the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa at ic.ac.uk)





More information about the Xml-dev mailing list